0 beğenilme 0 beğenilmeme
345 kez görüntülendi
Merhaba,

Geliştidiğim DLL'lerle dependency problemi yaşıyorum sanırım.

Sorun yaşamamak için TargetFramework ne olmalı?
Algoritmik Trading kategorisinde (25 puan) tarafından | 345 kez görüntülendi

1 cevap

0 beğenilme 0 beğenilmeme
Merhaba,

Framework 4.7.2 veya altı olmalı.

Seçkin Durgay
(3,921 puan) tarafından
0 0

Teşekkür ederim, sorunu buldum aslında ama çözemedim.

Ben strateji içinde RabbitMQ kütüphanesi kullanmaya çalışıyorum. Şöyle bir hata alıyorum.

"error CS0012: ReadOnlyMemory<>' başvurulmayan bir derlemede tanımlandı. 'System.Memory, Version=4.0.1.1, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51' derlemesine bir başvuru eklemelisiniz"

 

https://docs.microsoft.com/en-us/dotnet/framework/configure-apps/redirect-assembly-versions

Bu linkte anlatılana göre matriksIQ.exe.config dosyasına şöyle bir satır eklemem gerektiğini çıkarıyorum.

<dependentAssembly>
  <assemblyIdentity name="System.Memory" publicKeyToken="cc7b13ffcd2ddd51" culture="neutral" />
  <bindingRedirect oldVersion="0.0.0.0-4.0.1.1" newVersion="4.0.1.1" />
</dependentAssembly>

​

Bu değişikliği yaptım ama sorun çözülmedi. Bu çözülebilir bir sorun mudur?

Bana yardımcı olabilir misiniz?

2 0
Nasıl çözdüğümden emin değilim ama şu an çalıştırabildim.

Teşekkür ederim.
7,276 soru
7,289 cevap
4,289 yorum
6,471 kullanıcı